Cisco Material
シスコ設定の資料。

- Cisco Material -設定資料
- Cisco IOS Command Line Chart -コマンド一覧
- Cisco Numeric -ネットワーク関連の数値
- Cisco Lab -リモートラボの演習内容
- Cisco CCNA Simulatio -CCNAシュミレーション問題対策
- Javaプログラミング、サーブレット、JSPのまとめはこちら
- ITILファンデーション対策はこちら
マニュアル Catalyst 2900/3500 シリーズ XL ソフトウェア コンフィギュレーション ガイド
Cisco IOS Release 12.0(5)WC5および12.0(5)WC6
http://www.cisco.com/japanese/warp/public/3/jp/service/manual_j/lan/cat29/2935scg/

シスコ ルータでの DNS の設定
http://www.cisco.com/support/ja/105/reversedns.shtml

ホームルータ設定 IOS DHCP
http://warp.syns.net/7/4/

リカバリー Cisco Catalyst 2900 Disaster Recovery
http://www.omake-world.com/~fsting/inst_memo/catalyst2900_disaster.html

IOSの入手方法
http://okwave.jp/kotaeru.php3?q=1311180

CiscoCCNA対策ノート
http://www.geocities.jp/seidy_seidy/joho/CCNA_note.html

CiscoCCNAコマンド
http://www.geocities.jp/seidy_seidy/joho/CCNA_command.html

参考書籍 Cisco LANスイッチング―Cisco Catalystスイッチネットワーク設計のための完全ガイド
http://www.amazon.co.jp/exec/obidos/ASIN/4797318252/ref=pd_sim_dp_4/503-8391137-1364729

Tera term at Bangboo.com
http://www.bangboo.com/cisco/ttermp23.zip

Cisco network assistance at Bangboo.com
http://www.bangboo.com/cisco/cna-windows-k9-installer-3-1.exe

■作業環境
・ノートPC(OSはWin2000以降のもの、必ず最新パッチあてたもの)下記のソフトがインストールされていること
■PCにインストールしているソフト
 テラターム(通常のコンソール使用時)
 ハイパーターム(コンフィグバックアップ時)
 ・LANケーブル(ストレート・クロス1本ずつ)
 ・ラッキング用工具(プラスドライバー)
 ・電源タップ
 ・コンソールケーブル Dsub9ピン(オス/メス)
 ・USB変換コンソール(予備)
 ・3P-2P変換アダプタ
/////////////設定内容(CISCOスイッチ・ルーター)/////////////////
記載内容     更新:2001年11月30日 
ルーター: CISCO 811 
1、非武装地帯側のルータ(d2bri) cisco 811 
2、home.co.jp 側のルータ(h1bri) cisco 811 
3、ライン接続設定 
4、アクセスリストの設定 
5、アクセスリストのインターフェースへの適用 
6、設定の確認と保存 
スイッチ: CISCO 2924 
7、スイッチ(d2sw)cisco 2924 
8、スイッチ(d2asw)cisco 2924 
9、スイッチ(h1sw)cisco 2924 
10、設定の確認と保存 
 
      
1,非武装地帯側のルータ(d2bri) cisco 811


 基本セットアップ

router>setup
hostname d2bri
enable secret cisco
enable password cisco
telnet password telnet
snmp no
ip yes
igrp no
rip no
bridging no

 インターフェース設定

ethernet 0
ip yes
address 200.1.1.1
mask 255.255.255.0
bri 0
ip yes
adderss 10.1.1.1
mask 255.255.255.0

 ISDNの設定(d2 bri側)

configure terminal
interface bri0
ip address 10.1.1.1 255.255.255.0
encapsulation ppp
dialer map ip 10.1.1.2 name h1bri 0354349419
dialer-group 1
no fair-queue


2, home.co.jp 側のルータ(h1bri) cisco 811

 基本セットアップ

router>setup
hostname h1bri
enable secret cisco
enable password cisco
telnet password telnet
snmp no
ip yes
igrp no
rip no
bridging no

 インターフェース設定

ethernet 0
ip yes
address 222.1.1.1
mask 255.255.255.0
bri 0
ip yes
adderss 10.1.1.2
mask 255.255.255.0

 ISDNの設定 (h1 bri側)

configure terminal
interface bri0
ip address 10.1.1.2 255.255.255.0
encapsulation ppp
dialer map ip 10.1.1.1 name d2bri 0354349429
dialer-group 1
no fair-queue


3, ライン接続設定

ルーターへのコンソール接続 および TELNET接続の際のタイムアウトをなくす。 


d2bri側

d2bri>enable
d2bri#configure terminal
d2bri(config)#line console 0
d2bri(config-line)#exec-timeout 0 0
d2bri(config-line)#logging synchrous
d2bri(config-line)#exit
d2bri(config)#line vty 0 4
d2bri(config-line)#exec-timeout 0 0
d2bri(config-line)# ctrl+z
d2bri#

h1bri側

h1bri>enable
h1bri#configure terminal
h1bri(config)#line console 0
h1bri(config-line)#exec-timeout 0 0
h1bri(config-line)#logging synchrous
h1bri(config-line)#exit
h1bri(config)#line vty 0 4
h1bri(config-line)#exec-timeout 0 0
h1bri(config-line)# ctrl+z
h1bri#


4, アクセスリストの設定

d2bri#configure terminal
d2bri(config)# より
外部から内部へ(interface bri0に適用)
access-list 100 permit tcp any host 200.1.1.10 eq 80 log
access-list 100 permit tcp any host 200.1.1.10 eq 20 log
access-list 100 permit tcp any host 200.1.1.10 eq 21 log
access-list 100 permit tcp any host 200.1.1.20 eq 25 log
access-list 100 permit tcp any host 200.1.1.20 eq 53 log
access-list 100 permit tcp any host 200.1.1.30 log
access-list 100 permit udp any host 200.1.1.20 eq 53 log
access-list 100 permit udp any host 200.1.1.30 log
access-list 100 permit tcp host 222.1.1.11 any eq 23 log
access-list 100 permit icmp any any echo log
access-list 100 permit icmp any any echo-reply log
access-list 100 permit tcp any host 200.1.1.20 gt 1023 log
access-list 100 permit udp any host 200.1.1.20 gt 1023 log
内部から外部へ (interface eth0に適用)
access-list 110 permit icmp any any echo log
access-list 110 permit icmp any any echo-reply log
access-list 110 permit tcp any host 222.1.1.1 eq 23 log
access-list 110 permit tcp host 200.1.1.30 any log
access-list 110 permit udp host 200.1.1.30 any log
access-list 110 permit tcp host 200.1.1.20 any eq 53 log
access-list 110 permit udp host 200.1.1.20 any eq 53 log
access-list 110 permit tcp host 200.1.1.20 any gt 1023 log
access-list 110 permit udp host 200.1.1.20 any gt 1023 log
access-list 110 permit tcp host 200.1.1.20 any eq 25 log
access-list 110 permit tcp host 200.1.1.10 any eq 80 log
access-list 110 permit tcp host 200.1.1.10 any gt 1023 log
access-list 110 permit udp host 200.1.1.10 any gt 1023 log


5, アクセスリストのインターフェースへの適用

d2bri#configure terminal
d2bri(config)#interface s0
d2bri(config-if)#ip access-group 100 in
d2bri(config-if)#interface e0
d2bri(config-if)#ip access-group 110 in


6, 設定の確認と保存

 確認の為のコマンド

d2bri#show running-config
d2bri#show access-lists
d2bri#show interface

 保存

d2bri#copy running-config startup-config
d2bri#copy running-config tftp
Address or name of remote host ? 200.1.1.10
Destination filename[running-config]? Yes

     
7, スイッチ(d2sw)cisco 2924

 基本セットアップ

switch>setup
hostname d2sw
address 200.1.1.5
gateway 200.1.1.1
mask 255.255.255.0
enable secret cisco
telnet password telnet

 ポートセキュリティ

d2sw$enable
d2sw#configure terminal

 アドレステーブルの作成

d2sw(config)#mac-adderss-table secure ****.****.**** f0/1
d2sw(config)#mac-adderss-table secure ****.****.**** f0/2
d2sw(config)#mac-adderss-table secure ****.****.**** f0/3
d2sw(config)#mac-adderss-table secure ****.****.**** f0/24

 接続中の各インターフェースに適用

d2sw(config)#interface f0/*
d2sw(config-if)#port security max-mac-count 1
d2sw(config-if)#port security action shutdown

 空きportのセキュリティ

未接続の各インターフェースに適用
d2sw(config)#interface f0/*
d2sw(config-if)#shutdown


8, スイッチ(d2asw)cisco 2924

 基本セットアップ

switch>setup
hostname d2asw
address 192.168.1.2
gateway 192.168.1.1
mask 255.255.255.0
enable secret cisco
telnet password telnet

 ポートセキュリティ

d2asw$enable
d2asw#configure terminal

 アドレステーブルの作成

d2asw(config)#mac-adderss-table secure ****.****.**** f0/1
d2asw(config)#mac-adderss-table secure ****.****.**** f0/2
d2asw(config)#mac-adderss-table secure ****.****.**** f0/3
d2asw(config)#mac-adderss-table secure ****.****.**** f0/4
d2asw(config)#mac-adderss-table secure ****.****.**** f0/24

 接続中の各インターフェースに適用

d2asw(config)#interface f0/*
d2asw(config-if)#port security max-mac-count 1
d2asw(config-if)#port security action shutdown

 空きportのセキュリテイ

未接続の各インターフェースに適用
d2asw(config)#interface f0/*
d2asw(config-if)#shutdown
9, スイッチ(h1sw)cisco 2924

 基本セットアップ

switch>setup
hostname d2asw
address 222.1.1.5
gateway 222.1.1.1
mask 255.255.255.0
enable secret cisco
telnet password telnet

 ポートセキュリティ

h1sw$enable
h1sw#configure terminal

 アドレステーブルの作成

h1sw(config)#mac-adderss-table secure ****.****.**** f0/1
h1sw(config)#mac-adderss-table secure ****.****.**** f0/2
h1sw(config)#mac-adderss-table secure ****.****.**** f0/24

 接続中の各インターフェースに適用

h1sw(config)#interface f0/*
h1sw(config-if)#port security max-mac-count 1
h1sw(config-if)#port security action shutdown

 空きportのセキュリティ

未接続の各インターフェースに適用
h1sw(config)#interface f0/*
h1sw(config-if)#shutdown


10, 設定の確認と保存

 確認

d2sw#show running-config
d2sw#show mac-adderss-table
d2sw#show interface

d2asw#show running-config
d2asw#show mac-adderss-table
d2asw#show interface

h1sw#show running-config
h1sw#show mac-adderss-table
h1sw#show interface



 保存

d2sw#copy running-config startup-config

d2asw#copy running-config startup-config

h1sw#copy running-config startup-config